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I. BÀI TẬP TRẮC NGHIỆM.

Câu 1. HeidiSQL là gì trong ngữ cảnh của quản trị cơ sở dữ liệu?

A. Một công cụ quản lý cơ sở dữ liệu MySQL.
B. Một loại hệ điều hành.
C. Một trình biên dịch ngôn ngữ.


D. Một trình duyệt web.

Câu 2. Khi sử dụng HeidiSQL, để tạo một bảng mới, bạn nên thực hiện bước nào sau đây?

A. Nhấp chuột phải vào cơ sở dữ liệu và chọn "Delete Table".
B. Nhấn phải chuột vào tên cơ sở dữ liệu, chọn Create New ( Table.
C. Chọn tab "Query" và viết mã SQL tạo bảng.
D. Đóng ứng dụng HeidiSQL và mở lại để tạo bảng mới.

Câu 3. Để truy xuất thông tin từ hai bảng có liên kết bằng một khóa chung, ta sử dụng:

A. SELECT DISTINCT.

B. GROUP BY.
C. INNER JOIN.


D. ORDER BY.

Câu 4. Cơ sở dữ liệu là gì?

A. Một cấu trúc tổ chức dữ liệu.

B. Một phần mềm để lưu trữ dữ liệu.
C. Một tập hợp các file dữ liệu.

D. Một mô hình quản lý máy tính.

Câu 5. HeidiSQL là một công cụ quản lý Cơ sở dữ liệu nào?

A. MongoDB.

B. MySQL.

C. Oracle.

D. SQL Server.

Câu 6. Trong truy xuất dữ liệu qua các liên kết bảng, khái niệm nào mô tả việc kết nối dữ liệu từ nhiều bảng để lấy thông tin từ các dòng tương ứng?

A. Truy vấn.

B. Gộp.

C. Khoá ngoại.
D. Nhóm.

Câu 7. Để phóng to hoặc thu nhỏ ảnh trong GIMP, bạn sử dụng chức năng nào?

A. Smudge tool.
B. Zoom tool.

C. Flip horizontally tool.
D. Creative tool.

Câu 8. Cách nào sau đây là cách tạo một lớp mới trong GIMP?

A. Nhấn Shift+Ctrl + M.

B. Nhấn Shift+Ctrl + C.

C. Nhấn Shift+Ctrl + N.

D. Nhấn Shift+Ctrl + L.

Câu 9. Làm thế nào để khóa một lớp ảnh để ngăn chuyển đổi hoặc chỉnh sửa trong GIMP?

A. Chọn Layer > Merge Visible.
B. Chọn File > Save.
C. Chọn Select > All.


D. Chọn Layer > Nhấn vào biểu tượng Lock Layer.

Câu 10. Công cụ nào trong GIMP được sử dụng để điều chỉnh độ sáng của một hình ảnh?

A. Brush tool.

B. Brightness/Contrast tool.
C. Crop tool.

D. Eraser tool.

Câu 11. Công cụ nào trong GIMP được sử dụng chủ yếu để vẽ các đường, hình ảnh và hình dạng cơ bản?

A. Clone Tool.

B. Eraser Tool.

C. Brush Tool.
D. Gradient Tool.

Câu 12. Trong GIMP, để khóa một lớp ảnh và ngăn chuyển động không mong muốn, nên thực hiện thao tác nào sau đây?

A. Nhóm lớp.

B. Tạo lớp mới.

C. Xóa lớp.

D. Khóa lớp.

Câu 13. Trong quá trình xây dựng kịch bản, điều gì cần được xem xét để đảm bảo phim hoạt hình giao tiếp hiệu quả với khán giả?

A. Chọn một số lượng lớn nhân vật phụ.
B. Tạo ra những hiệu ứng đặc biệt nổi bật.
C. Tăng cường sử dụng ngôn ngữ hội họa.
D. Sử dụng ngôn ngữ phim học phổ biến.

Câu 14. Bạn cần thay đổi kích thước toàn bộ ảnh mà không làm thay đổi tỷ lệ chiều rộng và chiều cao. Lựa chọn nào dưới đây sẽ giúp bạn thực hiện điều này trong GIMP?

A. Chọn Scale Layer từ menu Layer.

B. Sử dụng Enlarge Image từ menu Image.
C. Click Zoom Out trực tiếp trên ảnh.
D. Sử dụng Crop and Zoom từ menu Edit.

Câu 15. Để chỉnh màu sắc của một phần cụ thể trong ảnh bằng Hue-Saturation trong GIMP, bạn sẽ sử dụng công cụ nào sau đây?

A. Move Tool.
B. Clone Tool.
C. Crop Tool.
D. Free Select Tool.

Câu 16. Làm thế nào để thêm phụ đề vào một đoạn video trong VideoPad?

A. Chọn "File" > "New Subtitle" > Nhập nội dung phụ đề > Xác nhận.
B. Chọn "Layer" > "Add Subtitle" > Nhập nội dung > Xác nhận.
C. Mở "Text" tool > Kéo đoạn vùng cần thêm phụ đề > Nhập nội dung.
D. Nhấn vào nút "Subtitles" trên thanh công cụ > Đặt con trỏ tại vị trí muốn phụ đề xuất hiện > Nhập nội dung phụ đề vào ô văn bản > Nhấn Add để thêm phụ đề mới hoặc Apply để áp dụng.

Câu 17. Để xuất file ảnh ở định dạng JPG trong GIMP, nên sử dụng tùy chọn nào sau đây?

A. File > Export As.


B. Edit > Copy.

C. View > Show Grid.

D. Layer > New Layer.

Câu 18. Trong GIMP, để làm cho một đối tượng trong ảnh nổi bật hơn bằng cách làm cho màu sắc của nó trở nên độc đáo, bạn sẽ sử dụng lệnh nào dưới đây?

A. Colors -> Hue-Saturation.

B. Filters -> Blur -> Gaussian Blur.
C. Colors -> Desaturate.


D. Tools -> Transform Tools -> Rotate.

Câu 19. Để áp dụng các hiệu ứng đặc biệt cho ảnh, người dùng thường sử dụng chức năng nào trong hộp chức năng "Filters" của GIMP?

A. Enhance.

B. Selection.

C. Transform.

D. Distort.

Câu 20. Bạn muốn tăng cường sự nổi bật của một hoa cúc trắng trong ảnh. Công cụ nào sẽ giúp bạn làm điều này trong GIMP?

A. Hue-Saturation.
B. Levels.

C. Curves.

D. Layer Color.

Câu 21. Công cụ Eraser trong GIMP được sử dụng để làm gì?

A. Xóa nội dung không mong muốn từ hình ảnh.
B. Tạo hiệu ứng màu Gradient.
C. Sao chép và tái tạo một phần của hình ảnh.
D. Vẽ bằng cách tô màu.

Câu 22. Để tạo hiệu ứng "Bóng đổ" cho một đối tượng trong ảnh bằng GIMP, bạn cần làm gì?

A. Vào Layer > Transform > Rotate 90 degrees.

B. Sử dụng Colors > Brightness-Contrast.
C. Chọn Filter > Light and Shadow > Drop Shadow.

D. Mở Tools > Selection Tools > Fuzzy Select.

Câu 23. Để thêm một bản nhạc nền vào video của bạn bằng VideoPad, thực hiện các bước nào sau đây?

A. Kéo và thả file nhạc trực tiếp lên ô "Audio Track" trong timeline.

B. Kích chuột phải vào timeline và chọn "Cut".
C. Nhấp vào biểu tượng hình loa để mở trình quản lý âm thanh.
D. Chọn "Rotate" để xoay video.

Câu 24. Làm thế nào để tạo một lớp mới khi muốn thực hiện thao tác cắt ảnh mà không làm thay đổi ảnh gốc trong GIMP?

A. Chọn Layer > New Layer.

B. Chọn Image > Resize.


C. Chọn File > Save.


D. Chọn Edit > Paste.



Câu 25. Làm thế nào để áp dụng một hiệu ứng màu sắc duyệt qua toàn bộ ảnh trong GIMP?

A. Mở hộp thoại "Filters" và chọn mục "Colors" để chọn hiệu ứng mong muốn.
B. Sử dụng công cụ "Clone" để sao chép màu từ một vùng khác.
C. Chọn công cụ "Eraser" và lau màu trắng lên hình ảnh.
D. Nhấp chuột trái và kéo chọn vùng cần áp dụng hiệu ứng màu.

Câu 26. Công cụ Paint Brush trong GIMP được sử dụng chủ yếu để:

A. Tạo vùng chọn.





B. Vẽ và màu sắc trên hình ảnh.
C. Sao chép nội dung từ một layer sang layer khác.
D. Điều chỉnh độ tương phản.

Câu 27. Trong phần mềm GIMP, để thực hiện thao tác "trong suốt" cho một lớp ảnh, bạn cần sử dụng tính năng nào sau đây?

A. Chuyển động tự do.

B. Mở rộng lớp.
C. Đặt mức độ trong suốt.

D. Chuyển đổi độ sáng.

Câu 28. Để điều chỉnh độ sáng và độ tương phản của video, cần sử dụng lệnh nào sau đây?

A. Filters > Distorts > Lens Distortion.

B. Filters > Artistic > Oilify.
C. Image > Transform > Flip Horizontally.
D. Colors > Brightness-Contrast.

Câu 29. Khi xuất khẩu ảnh động từ GIMP, định dạng file nào là lựa chọn phù hợp để đảm bảo ảnh có thể chạy trơn tru trên nhiều nền tảng khác nhau?

A. PNG.
B. GIF.

C. JPEG.

D. BMP.

Câu 30. Để áp dụng "Gradient Map" trong GIMP, bạn thực hiện các bước nào sau đây?

A. Colors > Desaturate.

B. Image > Rotate 90° Clockwise.
C. Colors > Map > Gradient Map.
D. Filters > Distorts > Lens Distortion.

Câu 31. Khi muốn xác định thời gian hiển thị của mỗi lớp trong ảnh động, bạn sử dụng tính năng nào trong GIMP?

A. Layer > Merge Down.


B. Layer > Layer Properties.
C. Filters > Animation > Playback.

D. Layer > Layer to Image Size.

Câu 32. Muốn thay đổi màu nền của một lớp trong hình ảnh để làm nổi bật một đối tượng. Làm thế nào để thực hiện điều này trong GIMP?

A. Nhấp đúp vào lớp và chọn "Edit" > "Fill with Color".
B. Kéo và thả màu mới từ bảng chọn màu lên lớp cần thay đổi.
C. Chọn "Image" > "Background Color" và chọn màu mới.
D. Click chuột phải vào lớp và chọn "Change Background Color".

Câu 33: Muốn truy xuất tất cả các dòng dữ liệu từ bảng "casi" ta dùng ?
A. SELECT * FROM casi WHERE tencasi LIKE '%Hoa%';
B. SELECT * FROM casi WHERE idcasi = 1;
C. SELECT * FROM casi;
D. SELECT * FROM casi WHERE tencasi LIKE 'N%';
Câu 34: Muốn truy xuất các ca sĩ theo thứ tự tên theo thứ tự từ A đến Z ta dùng ?
A. SELECT * FROM casi WHERE tencasi LIKE '%Hoa%';
B. SELECT * FROM casi WHERE idcasi = 1;
C. SELECT * FROM casi ORDER BY tencasi ASC;
D. SELECT * FROM casi WHERE tencasi LIKE 'N%';
Câu 35: Muốn truy xuất dữ liệu các ca sĩ có "idcasi" nằm trong danh sách (1, 2, 3) ta dùng ?
A. SELECT * FROM casi WHERE tencasi LIKE '%Hoa%';
B. SELECT * FROM casi WHERE idcasi = 1;
C. SELECT * FROM casi WHERE idcasi IN (1, 2, 3);
D. SELECT * FROM casi WHERE tencasi LIKE 'N%';
Câu 36: Để truy xuất  tất cả dữ liệu từ bảng "banthuam" ta dùng câu lệnh?
A. SELECT * FROM banthuam;
B. SELECT * FROM banthuam ORDER BY idbannhac ASC;
C. SELECT idbannhac, idcasi FROM banthuam;
D. SELECT * FROM banthuam WHERE idbannhac = 1; 
Câu 37: Để truy xuất dữ liệu từ bảng "banthuam" với điều kiện kết hợp giữa nhiều trường ta dùng câu lệnh?
A. SELECT * FROM banthuam WHERE idcasi = 2 AND banthuam >= 100; 
B. SELECT * FROM banthuam ORDER BY idbannhac ASC;
C. SELECT idbannhac, idcasi FROM banthuam;
D. SELECT * FROM banthuam WHERE idbannhac = 1; 
Câu 38: Để truy xuất dữ liệu từ bảng "banthuam" sắp xếp theo một trường cụ thể ta dùng câu lệnh?
A. SELECT * FROM banthuam;
B. SELECT * FROM banthuam ORDER BY idbannhac ASC;
D. SELECT * FROM banthuam WHERE idbannhac = 1; 
Câu 39: Để chỉnh sửa dữ liệu trong bảng ta thực hiện?
A. Nháy đúp chuột vào ô dữ liệu muốn sửa
B. Nháy nút trái chuột vào ô dữ liệu muốn sửa
C. Nhấn và giữ nút phải chuột vào ô dữ liệu muốn sửa
D. Đáp án khác
Câu 40: Khi Bảng bannhac có dữ liệu với trường idNhacsi tham chiếu đến trường idNhacsi của bảng nhacsi thì ta không thể?
A. Tùy tiện xóa các dòng của bảng nhacsi
B. Tùy tiện thay đổi dữ liệu trong bảng nhacsi
C. Tùy tiện thêm dữ liệu vào bảng nhacsi
D. Đáp án khác
II. BÀI TẬP ĐÚNG SAI.

Câu 1. Bạn cần thiết kế cơ sở dữ liệu cho một hệ thống quản lý thư viện. Trong đó, cần tạo bảng Sach để lưu thông tin về sách và bảng DocGia để lưu thông tin về độc giả. Bạn đã thiết kế lệnh SQL để tạo bảng Sach như sau:

CREATE TABLE Sach (

    MaSach INT PRIMARY KEY,

    TenSach VARCHAR(100) NOT NULL,

    TacGia VARCHAR(50),

    NamXuatBan INT,

    SoLuong INT DEFAULT 1

);

Hãy xác định các phát biểu sau đúng hay sai:

a) Lệnh SQL trên sẽ tạo một bảng có tên Sach với khóa chính là trường MaSach.

b) Nếu muốn tạo bảng DocGia có khóa ngoài tham chiếu đến bảng Sach, chỉ cần thêm trường MaSach vào bảng DocGia là đủ, không cần dùng từ khóa FOREIGN KEY.

c) Việc không chỉ định khóa chính cho bảng Sach sẽ không ảnh hưởng đến việc tạo các bảng khác có khóa ngoài tham chiếu đến bảng này.

d) Trường TenSach được thiết lập là NOT NULL, điều này đảm bảo mỗi cuốn sách trong cơ sở dữ liệu phải có tên và không được phép để trống.

Câu 2. Lan muốn tạo một banner đơn giản cho câu lạc bộ học sinh. Em sử dụng GIMP để ghép văn bản lên ảnh nền và điều chỉnh kích thước ảnh để đăng lên mạng xã hội.
Hãy xác định các phát biểu sau đúng hay sai:
a) Để thêm chữ vào ảnh, Lan có thể sử dụng công cụ “Text Tool” và nhập nội dung trực tiếp lên ảnh.
b) Lan có thể thay đổi màu chữ bằng cách chọn công cụ “Bucket Fill Tool”.
c) Lan cần chuyển đổi văn bản thành lớp riêng (text layer) để dễ dàng di chuyển hoặc chỉnh sửa sau này.
d) Khi muốn giảm dung lượng ảnh để đăng lên mạng, Lan nên sử dụng chức năng “Export As” và chọn định dạng JPG với mức nén phù hợp.

Câu 3. Minh đang sử dụng phần mềm GIMP để chỉnh sửa một bức ảnh chụp phong cảnh. Em ấy muốn làm nổi bật bầu trời và xóa bỏ một số chi tiết không mong muốn trong ảnh.

Hãy xác định các phát biểu sau đúng hay sai:
a) Để chọn vùng bầu trời, Minh có thể sử dụng công cụ "Fuzzy Select Tool".
b) Sau khi chọn vùng, Minh có thể nhấn phím Delete để xóa phần được chọn.
c) Minh không thể dùng Layer Mask để ẩn tạm thời một phần của ảnh thay vì xóa vĩnh viễn.
d) Nếu Minh muốn khôi phục vùng đã xóa, thao tác “Undo” hoặc sử dụng “History” sẽ giúp quay lại các bước trước đó.
Câu 4. An đang làm một video giới thiệu trường học bằng phần mềm VideoPad. Em muốn chèn hình ảnh, thêm nhạc nền và đặt tiêu đề mở đầu video.

Hãy xác định các phát biểu sau đúng hay sai:
a) Để thêm hình ảnh vào video, An có thể nhấn nút "Add Media" hoặc kéo thả trực tiếp ảnh vào giao diện.
b) VideoPad không cho phép thêm nhạc nền bằng cách chèn tệp âm thanh vào dòng thời gian audio.
c) An nên đặt tiêu đề mở đầu vào lớp (track) riêng để dễ dàng di chuyển và điều chỉnh hiệu ứng.
d) Khi sắp xếp nhiều ảnh theo thứ tự, An cần kéo chúng vào timeline video theo đúng trình tự mong muốn.
Câu 5. Bình đang chỉnh sửa một video ngắn giới thiệu sản phẩm bằng VideoPad. Em muốn cắt bỏ đoạn đầu video, thêm hiệu ứng chuyển cảnh và xuất video thành file MP4.

Hãy xác định các phát biểu sau đúng hay sai:
a) Để cắt bỏ phần đầu video, Bình có thể sử dụng công cụ Split rồi xóa đoạn không cần thiết. 

b) VideoPad không hỗ trợ thêm hiệu ứng chuyển cảnh bằng cách chèn hiệu ứng vào điểm nối giữa hai clip. 

c) Khi xuất video, VideoPad cho phép chọn định dạng MP4 trong phần “Export Video”. 

d) Bình có thể tạo bản sao (duplicate) clip và áp dụng hiệu ứng khác nhau để so sánh trước khi quyết định sử dụng.
III. BÀI TẬP TỰ LUẬN.

Câu 1. a) Cho bảng hocsinh có dữ liệu như sau: 
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Viết câu lệnh truy vấn dữ liệu trong bảng hocsinh để hiển thị tất cả trường với điều kiện tên của học sinh có chứa từ ‘An’.
Câu 2. Giả sử cơ sở dữ liệu về quản lý học sinh có bảng hocsinh ở trên, ngoài ra còn có thêm các bảng monhoc và diemhoctap với thông tin các trường như sau:

monhoc(mamonhoc, tenmonhoc)

diemhoctap(mahocsinh, mamonhoc, diemtx, diemgk, diemck)

Viết câu lệnh truy xuất dữ liệu để có kết quả như hình sau: 
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Câu 3. Trình bày cách sử dụng công cụ Free Select Tool trong GIMP để chọn và cắt một vùng ảnh theo hình dạng bất kỳ.
Câu 4. Nêu các bước căn chỉnh thời gian các phân cảnh của video clip khi thực hiện trên phần mềm VideoPad?

Câu 5. Nêu các bước tạo hiệu ứng chuyển cảnh khi làm video clip trên phần mềm VideoPad?
